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Migrating from Autodesk Eagle to OrCAD X

Overview

Choosing the right PCB design solution is never an easy task. No matter if you are a startup company looking for tools to
develop your next innovative electronic product or a large enterprise wanting a better solution to improve the productivity of
your design team, selecting a PCB solution can be a daunting task. No one wants to get 75% of the way through a design to
find out that the software you selected is not going to achieve what you need to accomplish.

Before you select a PCB design software package, there are many performance and capability aspects you should consider
first:

> Does the capabilities of the application and its technology meet your design requirements?
> Does the design software licensing fit within your budget?

> What level of support can you expect? Will you be able to get quick responses to your questions and access online tutorials?
Is local help available?

» Can the application scale with your needs? As designs are getting more and more complex, will the capabilities of the tool
adjust accordingly?

» How many other companies in your industry are using this tool and what is their feedback?

OrCAD X® offers an excellent solution for individual designers, small design teams, and large enterprises. You can be confident
that you will have the right solution and technologies at an affordable price to meet all of your design challenges today and
tomorrow. Here are five of many reasons why:

» 30 years of innovation and leadership in the industry
» Affordable price and flexible purchase models

» Cutting-edge technologies

> Ecosystem empowered

> Industry’s best customer support

Like many companies selecting OrCAD X, you have existing or legacy designs you need to convert or translate into OrCAD X.
The good news is that OrCAD X is supplied with an integrated and proven Eagle design translator built in. This guide will walk
you through the steps and process involved in getting your design IP into the OrCAD X format so you can start realizing the
advantages of moving to OrCAD X!

» Watch how Eagle Schematic and PCB data are migrated to OrCAD X.

» Watch how Eagle footprint libraries are migrated to OrCAD X.
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Import Your Eagle Schematic Data to OrCAD X Capture

STEP 1 - Preparation

Before you start translating your Eagle schematic data into OrCAD X Capture, the schematic must be in XML format. If this is
not the case, open the schematic in Eagle version 6.5 or later and save the schematic as a .SCH file.

STEP 2 - Import the Eagle Schematic into OrCAD X Capture

In OrCAD X Capture, select “File » Import » Eagle Schematic Translator” to launch the Eagle to Capture translator. Browse to
the schematic file to be translated (.SCH). Then specify an output directory for the OrCAD X project. Click on “Translate” button.

Import Eagle Schematic Build 74 |

Eagle .SCE—IIE LB

OrCAD outputpath |C:/_PE/ORCADX_Intro_Movies/How to Eagle Import/BigEasyDriver_v16a
Leave this field blank if the output files are located in the same directory as the source (.sch)file

v Cleanup intermediate files

v Force labels on unconnected wires

Translate Cancel Help

Leave the OrCAD X output path blank if the output files should be located in the same directory as the source ((SCH) file.

After the Translate operation completes, give the project a name. As an option, PSpice Simulation can be enabled when
naming the project.

Select Project Type

dezigh

Enable PS5 Simulation

If there are no data or formatting errors in the Eagle .SCH file, the converted data will be available in a .DSN file. The translator
will also create a library ((OLB file) for the design.

Once the design has finished translating, open the project and check the schematic for any errors. A quick way to scan for
problems is to check the DRC panel at the bottom of the screen.
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Note: Make sure to check the log file shown after translation. The log file will be found in the same folder as the translated
project files. The log will show what happened during the Schematic translation process, such as pin replacements, which
sheets were created from schematics, symbols created in libraries, creation of off-page connectors, and other important
information.

Import Eagle Schematic Build: 69 Untited-1 @

269 Added offpage connectors
261 '2.5.8V VCC_5.@' Capture coord (158, 4&)

262 "GND' [ ure coord (328,  48)

263 '5.5.5-36V_VOC_BATT' Capture coord. (49@, 48)

264

265

266 sheat #4(PAGE4) size : MIN WIDTH=-28  MIN HEIGHT=-18 MAX WIDTH=1535 M&X HEIGHT=1132
267

268 (€-US, Mame=C85, Value=8.1uF _ 16V} (X=462, ¥=462) ¥=472, ¥=557 WARNING : Mot on Grid
264 (C-US, Mame=C87, Valus=18uF _ 15V) (X=588, Y=SBB) =518, Y=557 WARNIMNG : Not on Grid
78 (C-US, Mame=C23, Value=22uF) (X=378, Y-978) X-088, ¥Y=557 WARMING : Not on-Grid

71 (TP562111, Name=IC5, Value=TPS62111) (X=678, Y=G78) X=648, Y=517 WARMING : Not on Grid
2372 [L-US, Mame=L7, Valus=4.BuH) (X=85H, ¥ 1] K ¥=517 WAANING : Mot on- Grid

5 =547 WARNING : Hot on Grid

8, Y=G17 WARNING : Mot on-Grid

5 ¥=557 WARNING - : -Not - on-Grid
¥=547 WARNING: : Mot on-Grid
Y=557 WARNIMNG : Mot on-Grid
» ¥=517 WARNIMG : Mot on-Grid

273 (R-US, Mame=R21, Walue-BR) (X=9 ]
274 (R-US, Mame=R24, Value=DNP)  (X=213, ¥
275 (C-US, Mame=C92, Value=1@8pF) (X=248,
276 [R-US, Mame=R1%, Walus=1M8) (X=HE5H
(C-Us, Mame=C28, value=1.8uF)
278 (R-US, Mame=R23, Value-@R) {X=-1858, Y-1853) X=-1

274

288  Replaced part name/value

281 C-US: Partvalue '@.1uF / 16V' replaced by "@.1uF-_ - 16V’
282 C-U5: Partvalue '18uF-/ 16Y' replaced by '18uF 16V

Portion of a translation log file. The log file may include warnings that should be inspected in the translated schematics.

Before creating a netlist for PCB synchronization, you'll now need to translate the Eagle PCB data using OrCAD PCB Editor. Do
not close the project in OrCAD X Capturel

Import Your Eagle PCB Data to OrCAD X Presto PCB Editor

STEP 1 - Preparation

Before you start translating your Eagle schematic data into OrCAD X Presto PCB Editor, the schematic must be in XML format.
If this is not the case, open the schematic in Eagle version 6.5 or later and save the schematic as a .BRD file.

STEP 2 - Create a New Board

Start OrCAD X Presto PCB Editor.

Select “File » New » Board”

OrCAD X Preste Professional
File | Edit View Help
New . 4 Board
B Open Ctrl+0 Footprint
Open Recent 4

Symphony Connect

B SaveAll

Import

Ctrl+5S

Export
Reset Default License
X Exit Alt+F4
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STEP 2 - Import the Eagle PCB Design into OrCAD X Presto PCB Editor
In OrCAD X Presto PCB Editor.

Select “Import » Translators » Eagle PCB”.

a OrCAD X Preste Professional
File Edit View Setup Tools ECO  Manufacturing

New »
~ Open Ctrl+0

Open Recent »

Symphony Connect
E Save Untitled.brd Ctrl+S Off

HE Save As
i Import PADS...
3D Export PADS Library...
Reset Default License Altium PCB...
X Exit Alt+F4 Eagle PCB... A

~ Digndis  Fianes | UIEIeCtiics, iviasks

The Eagle PCB and Library Translator window will appear. From here you can select your .BRD and .LBR files to translate into
OrCAD X's file format.

a Eagle PCB and Library Translator - X

Skip log details (timesaving on large boards)

Translate Close

Browse to the Eagle PCB file and select “Open”, the path to the file will appear in the text box.

www.cadence.com 5



Migrating from Autodesk Eagle to OrCAD X

Select Eagle board file x

Look in: B C\_PE\ORCADX Intro_Movi... Import\BigkasyDriver t1 ¥ & & @ ¢ H B

.. Desktop Name

5 Documents B BIGEASYDRIVER_V16A-PSpiceFiles
E jcarney o« BigEasyDriver_v16a.brd

File name: |

Files of type: |Eagle board(*.brd) Cancel

Click "Translate” to begin the conversion process. The Command window will show the translation progress. Once the trans-
lation finishes, the translated .BRD file will be accessible in the same folder as the original Eagle board.

Note: In some cases, especially for larger boards, it might seem like PCB Editor has stopped working. Do not close it as tests
on large boards have shown translation times taking over five minutes, although this is unusual.

Note: Make sure to check the log file after the translation completes. The log file will contain all the text shown in the
Command window once the translation completes; this file can be found in the same folder as your translated .BRD file.

The most important part is in the Translation statistics section, which is where the net and component count in the Eagle
board are compared with the data in the translated board.

Iranslation statisticsa
Compeonents: Eagle 30 -> 30 on translated board
Nets: Eagle &8 -» 68 on translated board

Warningsa
Duplicate footprint names found!
Fix issue backannctating footprint names from PCB Editor to OrCAD Capture.
Backannctation file created "sample backannc.awp” in F:/import/
In OrCAD Capture do the following
1. Go toc Project Manager
. Jelect "Toocls -» Back Annctate”
. Jelect "Layocut"™ tab. Otherwise never use this tab of the dialcg for PCE Editer.
. Browse and select the backannctaticn file menticned above
. Click "CE" to update the schematic design in OrCAD Capture with correct footprint names

0o L R

After the above steps are performed a netlist can be created in OrCRAD Capture and imported to PCB Editor.

The log can show two important warnings. Only one of them is present in this board.
“Nets with no pins found” (Not shown in this example.)
The statistics above this warning show the net count in both the original Eagle board and the translated PCB Editor board file.

If there is a mismatch, it is typically caused by “free” vias placed in Eagle. They are automatically assigned net names. This
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type of via will not have any net connection to the schematic and the net attachment is removed during netlistimport. The
same situation can occur if two or more free vias are placed and connected with a wire (cline) in Eagle but without being
connected to a pin.

The translator will check if a net has any pin attachment and if not, warn that this is the case. The log file will show all the nets
without any pin attachment and also report what the net count should be after netlist import.

“Duplicate footprint names found!”

This warning means that a backannotation process is needed to match the footprint names in the translated board to match
the footprint names in the translated schematic design. All steps involved are listed in the log, and a backannotation ((SWP)
file will be generated for immediate use in OrCAD X Capture.

If a duplicate footprint name is found, only the first located instance will use the original footprint name. All future instances
that are found during translation will use the modified footprint library name. In the example swap file for backannotation, C4
uses a “E2_5-5" footprint, as does C7 but from a library named RESISTOR, and the footprint is renamed to libraryname_
footprintname.

"C2" "C5B2_SA"
"c4m "E2_5-5"

"Cs" "E2 5-5" \
"U1" "TO220H"

"U2" "TO220H"
"RS" "0207_10"
"R4™ "0207_10"
"R2" "0207_10"
"R1" "0207_10"
"D1" "D041210"
"R3" "0207_10 1"
"JP1" "1X02"
"Cc1" "E35-16"
"Cé" "E2_5-5"
"C7" "RESISTOR_E2_5-5"

library name added
before footprint name

If there is no duplicate footprint warning in the log file, the back annotation process can be skipped. In that case, move ahead
to “Synchronizing OrCAD X Capture and PCB Editor Design”.

STEP 3 - Backannotating Footprint Names from PCB Editor to OrCAD X Capture

Note: This step is only necessary if the bottom part of the translation log file states “Duplicate footprint names found”. In
this case, a swap ((SWP) file will be created in the same directory as the translated board file. If there is no swap file, then you
can skip this section and move ahead to “Synchronizing OrCAD X Capture and PCB Editor”

Go back to OrCAD X Capture without closing OrCAD X Presto PCB Editor.

Select “Tools » Back Annotate” menu item in OrCAD X Capture.
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** OrCAD X Capture CIS-|/ - (SCHEMATIC1 : PAGE1)]

File Design Edit View Tools Place PCB Sl Analysis

- — ¥4 Annotate...
EmBes -
2 Back Annotate...
BIGEASYDRIVER_V16A.0pj
Update Properties...
Analog or Mixed A/D

Test Bench

Create Netlist...
Create Differential Pair..
Cross Reference...
@ Design Cacl InterSheet References..
& Library BR Bl of Materials...
@ Layout
& Outputs

Select the “Layout” tab; from here you can select the .SWP file required for backannotation. Select “Browse” and select the .
SWP file created by the Eagle PCB translator.

Backannotate

PCB Editor

Update Instances (Prefemed)

Back Annotation File

T\DEVICES\BIGEASYDRIVER_V16A.SWP Browse

Cancel

Click “OK" to update the OrCAD X Capture project with the footprint names in the board file. Check the Capture session log
“Window » 1. Session Log” to check that all parts were updated. Now the design is ready for synchronization.
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Synchronizing OrCAD X Capture and Presto PCB Editor

STEP 1 - Creating and Importing the Netlist in OrCAD X Capture
Select “PCB » Update Layout”.

Create Metlist

EDIF200 INF PSpice SPICE Werilog WVHDL Other

CB Footprint
bined property string:
PCB Footprint

Metlist Files Directory: C:\sers\allegro

Select the translated Eagle board file “OK" to create the netlist and accept saving the project and creating an allegro subdi-
rectory.

New Layout
Create New Layout and Associate in Project
PCB Layout Folder allegro

Input Board File

Board allegro\bigeasydriver_v16a.brd

Cancel Help

Note: Once translated, the OrCAD X board database will have _allegro in the file name differentiating it from the Eagle board
database.

B Input Board File X
Look in: | BigEasyDriver_t1 vl Q2 mE
* Name ~ Date modified Type
: BIGEASYDRIVER_V16A-PSpiceFiles 2/8/2024 10:47 AM File fc
GUERSCEES devices 2/8/202410:49 AM Filefc
| BB BigEasyDriver_vi6a.brd 11/10/2016 3:36 PM BRDf
2] BiﬁasyDriver_ﬂ 6a_allegro.brd 2/8/2024 10:49 AM BRDf
Desktop
-
Libraries
This PC
L 4 ,
Network
Fie name: [ v [oeen_]
Fiesof type: |Board Files (*brd) v [ Cancel |
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STEP 2 - Check Design Status

Check the Properties Panel for the design status of the project. There may be Unrouted Nets or Connections.

Properties

Q Search

¥ Selection Filter

All Objects | Groups

Trace Segments Traces Line Segments Lines Wires Vias
Fingers Components Pins Shapes Voids Text DRC
Nets Connections Virtual Points

V¥ Status

Unplaced Components
Unrouted Nets
Unrouted Connections
Shape Islands

Unassigned Shapes

Out of Date Shapes

DRC Up to Date
0 Design(14)
@ Spacing(1)

DRC Errors # Shorting Errors 4

Waived Errors Waived Shorting Errors

Highlight DRC on Canvas

STEP 4 - Check Physical and Spacing DRC Constraints

From OrCAD X Capture, start the Constraint Manager from the “PCB » Constraint Manager” menu item. Check and verify the
physical and spacing DRC rules. Update the online DRC using the toolbar icon.

STEP 5 - Change to Preferred Colors

Changing the colors to suit your preferences is easy. Select the color and visibility toolbar icon and change your color prefer-
ences accordingly.

Importing Eagle PCB Libraries into OrCAD X Presto PCB Editor

STEP 1 - Preparation

Before you start translating your Eagle PCB footprint library into OrCAD X Presto PCB Editor, the library data must be in XML
format. If this is not the case, open the library in Eagle version 6.5 or later and save the library as a .LBR file.

STEP 2 - Import the Eagle PCB Footprint Library into OrCAD X Presto PCB Editor

All the footprints in the library are imported to a board file. After the translation, they can be exported as individual footprints
and padstacks.

Start OrCAD X Presto PCB Editor.

Select “Import » Translators » Eagle PCB”.
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Click “Translate” and make sure to change the filetype to “Eagle library (*.LBR)".

Browse to the Eagle library file (LBR) and select “Open” and the translation starts. Make sure to select Eagle library(*.Ibr) in
the “Files of type” dropdown menu.

Select Eagle board file X

Look in: W C\SPB_Data v & 95 2 ﬂ* E E

=/ My Computer Name Type Date Modified

F fyanw cdssetup File...lder
pcbenv File...Ider
signoise.run File...|der :
Untitled.brd 12..KiB brd File

o Untitled_1.brd B brd File
oe Untitled_2.brd 12...KiB brd File

File name:

Files of type: e Cancel

The command window shows the translation progress.

Note: In some cases, especially for larger libraries, it might seem like Presto PCB Editor has stopped working. Do not close
PCB Editor; leave it running until the process completes.

Note: After the translation is finished, a log file will show what was done during translation.

If you have any questions about the migration or in general about OrCAD X, please do not hesitate to contact your local
Cadence Channel Partner at http://orcad.com/about/contact-us.
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Cadence is a pivotal leader in electronic design and computational expertise, using their Intelligent

System Design Strategy to turn design concepts into reality. Cadence customers are the world’s
- ® most creative and innovative companies, delivering extraordinary electronic products from

c a d e n c e chips to boards to systems in the most dynamic market applications. www.cadence.com




